관리 메뉴

Joonas' Note

PHP4 to PHP5.4 or higher 본문

개발

PHP4 to PHP5.4 or higher

joonas 2019. 11. 6. 07:59

자료를 정리하다 우연히 옛날에 개발하면서 생겼던 버그와 해결법이 있어서 공유

2014년 11월 즈음에, 아주 오래된 CentOS 5.x 운영체제에서 돌아가는 PHP 사이트를 관리하던 시절이 있었다.
꽤 많은 업데이트와 보안 패치 등을 위해서 PHP 버전을 업그레이드하려고 핬다. (PHP4에서 PHP5.4로)

당시에 CentOS의 yum 패키지 매니저로 아주 고생한 기억이 난다. yum의 의존성은 어떻게 잘 해결했다고 치고, 위 문제는 libedit.so.0을 패키지에 추가해서 해결했다.

반응형
Tag
, ,
0 Comments
댓글쓰기 폼